Increased AWS API error rates and latencies

Incident Report for Dizzion

Resolved

AWS reported issues with increased error rates and delays with certain API responses. As a result of this, some actions on our Frame platform were not processed or were processed slower than usual. Once AWS confirmed the issue was resolved, Dizzion made sure our platform addressed any outstanding requests.
Posted Apr 08, 2025 - 12:15 PDT

Identified

AWS is reporting issues with increased error rates and delays with certain API responses. As a result of this, some actions on our Frame platform are not being processed or are processing slower than usual.
Posted Apr 08, 2025 - 09:32 PDT
This incident affected: Frame Platform (Frame Platform (use.difr.com)).